hdu 1010 Tempter of the Bone【DFS】

Tempter of the Bone

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

Output

For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

Sample Input

4 4 5
S.X.
…X.
…XD

3 4 5
S.X.
…X.
…D
0 0 0

Sample Output

NO
YES

題意解析

dfs+剪枝
從起點S開始搜索,然後直到D點結束。但是注意步數要要固定爲t和走過的路不能重複走這兩點。因爲搜索可能會超時所以就需要剪枝,奇偶剪枝,就是每一步到終點的步數奇偶性要與剩餘步數奇偶性相同。

程序代碼 C

#include <stdio.h>
#include <math.h>
#include <string.h>
int n,m,t,flag;
char s[10][10];
int book[10][10];
int sx,sy,dx,dy; 
int next[4][2]={{0,1},{1,0},{0,-1},{-1,0}};

void dfs(int x,int y,int step){
	//printf("%d-%d\n",step,t);
	int i,k,f,tx,ty;
	if(x==dx&&y==dy&&step==t)
		flag=1;
	if(flag==1||step>=t)
		return ;
	f=abs(x-dx)+abs(y-dy);
	if(f%2!=(t-step)%2)
		return ;
	for(k=0;k<4;k++){
		tx=x+next[k][0];
		ty=y+next[k][1];
		if(tx<0||ty<0||tx>=n||ty>=m)
			continue;
		if(book[tx][ty]==0&&s[tx][ty]!='X'){
			book[tx][ty]=1;
			dfs(tx,ty,step+1);
			book[tx][ty]=0;
		}
	}
	return ;
}

int main()
{
	int i,j,k,f;
	while(scanf("%d%d%d",&n,&m,&t)){
		if(n==0&&m==0&&t==0)
			break;
		flag=0;
		for(i=0;i<n;i++){
			scanf("%s",s[i]);
			for(j=0;j<m;j++){
				if(s[i][j]=='S')
					{ sx=i; sy=j;}
				if(s[i][j]=='D')
					{ dx=i; dy=j;}
			}
		}
		memset(book,0,sizeof(book));
		book[sx][sy]=1;
		if(n*m>=t)
			dfs(sx,sy,0);
		if(flag)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章