HDU 5546 dfs深搜四連塊

Ancient Go

Problem Description
Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

⋅The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
⋅Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
⋅The chess of the same color makes connected components(connected by the board lines), for each of the components, if it’s not connected with any of the empty cells, this component dies and will be removed from the game board.
⋅When one of the player makes his move, check the opponent’s components first. After removing the dead opponent’s components, check with the player’s components and remove the dead components.
One day, Yu Zhou was playing ancient go with Su Lu at home. It’s Yu Zhou’s move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu’s chess.

Input
The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. ′.′ represents an empty cell. ′x′ represents a cell with black chess which owned by Yu Zhou. ′o′ represents a cell with white chess which owned by Su Lu.

Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu’s components. Can not kill in one move!!! otherwise.
Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu’s components. Can not kill in one move!!! otherwise.

Sample Input
2

…….xo
………
………
..x……
.xox….x
.o.o…xo
..o……
…..xxxo
….xooo.

……ox.
…….o.
…o…..
..o.o….
…o…..
………
…….o.
…x…..
……..o

Sample Output
Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!
Hint

In the first test case, Yu Zhou has 4 different ways to kill Su Lu’s component.

In the second test case, there is no way to kill Su Lu’s component.

題目鏈接 http://acm.hdu.edu.cn/showproblem.php?pid=5546

題目大意

給個9x9的棋盤,判斷'x'能不能一步就殺死'o'。

題解

dfs求連通塊,從每一個'o'出發dfs,計算周圍'.'的個數,注意是4連塊不是8連塊,每次dfs前要清空used,遍歷過的'.'一定要標記,否則會重複計算。
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>
#include <stack>
#include <queue>
#include <vector>
#define INF 0x3f3f3f3f 
using namespace std;
const int maxn = 10;
char pic[maxn][maxn];
int used[maxn][maxn];
int m=9, n=9;
int dr[4] = {-1,0,1,0};
int dc[4] = {0,1,0,-1};

void dfs(int r, int c, int &cnt){
    if(r<0 || r>=m || c<0 || c>=n) return;
    if(used[r][c]) return;
    if(pic[r][c] == 'x') return;
    if(pic[r][c] == '.'){
        used[r][c] = 1;//標記'.'
        cnt ++;
        return;
    }
    used[r][c] = 1;
    for(int i=0; i<4; i++){
        dfs(r+dr[i], c+dc[i], cnt);
    }
}

int main(){
    int t;
    scanf("%d", &t);
    for(int cas = 1; cas<=t ; cas++){
        for(int i=0; i<m; i++){
            scanf("%s", pic[i]);
        }
        int flag = 0;
        for(int i=0; i<m; i++){
            for(int j=0; j<n; j++){
                memset(used, 0, sizeof(used));//清空used
                if(pic[i][j] == 'o'){
                    int cnt = 0;
                    dfs(i, j, cnt);
                    if(cnt == 1){
                        flag = 1;
                        break;
                    }
                }
            }
        }
        if(flag){
            printf("Case #%d: Can kill in one move!!!\n", cas);
        }
        else{
            printf("Case #%d: Can not kill in one move!!!\n", cas);
        }
    }
    return 0;
} 
/*
以下是測試樣例,如果都能過程序應該就沒問題了
......... 
......... 
......... 
......... 
...xxx... 
..xooox.. 
..xxo.... 
....x.... 
......... 

o.o...ox. 
x......o. 
o.xo..... 
..oxo.... 
...o..... 
......... 
.......o. 
o........ 
oox...... 

ooooooooo 
xx.xxxxx. 
xxxo..... 
......... 
......... 
......... 
......... 
......... 
......... 

......... 
...xx.... 
..xoox... 
..xox.... 
....xx... 
..xooo... 
...xxx... 
......... 
......... 


..x.x.... 
.xo.ox... 
.xooox... 
..xxx.... 
......... 
......... 
......... 
......... 
......... 
*/
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章