uva1639 Candy 數學期望 對數處理精度

1639 Candy


LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy
boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first
box with probability p and the second box with probability (1 − p). For the chosen box, if there are
still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no
candy left. Before opening the other box, he wants to know the expected number of candies left in the

other box. Can you help him?


Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2×10 5 ) and a real number
p (0 ≤ p ≤ 1, with 6 digits after the decimal).

Input is terminated by EOF.


Output
For each test case, output one line ‘Case X: Y ’ where X is the test case number (starting from 1)
and Y is a real number indicating the desired answer.

Any answer with an absolute error less than or equal to 10 −4 would be accepted.


Sample Input
10 0.400000
100 0.500000
124 0.432650
325 0.325100
532 0.487520

2276 0.720000


Sample Output
Case 1: 3.528175
Case 2: 10.326044
Case 3: 28.861945
Case 4: 167.965476
Case 5: 32.601816

Case 6: 1390.500000



參考紫書333頁,方法同樣

P(ξ=K)= C(n,k) * p^k * (1-p)^(n-k), 其中C(n, k) = n!/(k! * (n-k)!)

得出第i次打開盒子1沒糖的概率C(2n-1,n)p^(n+1)(1-p)^(n-i)
得出第i次打開盒子2沒糖的概率C(2n-1,n)(1-p)^(n+1)p^(n-i)
第i次打開盒子沒有糖的概率就爲上述兩式相加,根據期望公式每次與i相乘求和則爲總期望



#include<cmath>
#include<cstdio>
using namespace std;
typedef long double LD;
const int MAX = 2*1e5+5;
LD logF[2*MAX];

LD logC(int n,int m){ //計算C(n,m)的對數 In(C(n,m))
    return logF[n]-logF[m]-logF[n-m];
}

int main()
{
    for(int i=1;i<=400005;++i) logF[i]=logF[i-1]+log(i); //預處理In(n!)

    int n,cas=1;double p;
    while(scanf("%d%lf",&n,&p)==2)
    {
        double ans=0.0;
        for(int i=1;i<=n;i++){
            LD c=logC(2*n-i,n);
            LD v1=c+(n+1)*log(p)+(n-i)*log(1-p);
            LD v2=c+(n+1)*log(1-p)+(n-i)*log(p);
            ans+=i*(exp(v1)+exp(v2));
        }
        printf("Case %d: %f\n",cas++,ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章