A+B for Input-Output Practice (IV)

Problem Description
Your task is to Calculate the sum of some integers.
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Sample Input
4 1 2 3 4
5 1 2 3 4 5
0
Sample Output
10
15

C

#include <stdio.h>
#pragma warning(disable:4996)
int main(void)
{
 int sum,input,i,n;
 while(scanf("%d",&n)&&n)
 {
  for(i=0,sum=0;i<n;i++)
  {
   scanf("%d",&input);
   sum+=input;
  }
  printf("%d\n",sum);
 }
 return 0;
}

每行第一個數字表示接下來要給的數字數量,寫在while循環裏。
然後for循環讀入剩餘的數字並相加,for循環結束後輸出和。
注意:
C語言用除0以外的任何數表示真,所以在n=0時,while循環結束。
每次計算後要把sum的值歸0。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章