Spreadsheet

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)

Problem Description
In 1979, Dan Bricklin and Bob Frankston wrote VisiCalc, the first spreadsheet application. It became a huge success and, at that time, was the killer application for the Apple II computers. Today, spreadsheets are found on most desktop computers.

The idea behind spreadsheets is very simple, though powerful. A spreadsheet consists of a table where each cell contains either a number or a formula. A formula can compute an expression that depends on the values of other cells. Text and graphics can be added for presentation purposes.

You are to write a very simple spreadsheet application. Your program should accept several spreadsheets. Each cell of the spreadsheet contains either a numeric value (integers only) or a formula, which only support sums. After having computed the values of all formulas, your program should output the resulting spreadsheet where all formulas have been replaced by their value.

Figure: Naming of the top left cells

Input
The first line of the input file contains the number of spreadsheets to follow. A spreadsheet starts with a line consisting of two integer numbers, separated by a space, giving the number of columns and rows. The following lines of the spreadsheet each contain a row. A row consists of the cells of that row, separated by a single space. A cell consists either of a numeric integer value or of a formula. A formula starts with an equal sign (=). After that, one or more cell names follow, separated by plus signs (+). The value of such a formula is the sum of all values found in the referenced cells. These cells may again contain a formula. There are no spaces within a formula. You may safely assume that there are no cyclic dependencies between cells. So each spreadsheet can be fully computed. The name of a cell consists of one to three letters for the column followed by a number between 1 and 999 (including) for the row. The letters for the column form the following series: A, B, C, …, Z, AA, AB, AC, …, AZ, BA, …, BZ, CA, …, ZZ, AAA, AAB, …, AAZ, ABA, …, ABZ, ACA, …, ZZZ. These letters correspond to the number from 1 to 18278. The top left cell has the name A1. See figure 1.
在這裏插入圖片描述

Output
The output of your program should have the same format as the input, except that the number of spreadsheets and the number of columns and rows are not repeated. Furthermore, all formulas should be replaced by their value.

Sample Input
1
4 3
10 34 37 =A1+B1+C1
40 17 34 =A2+B2+C2
=A1+A2 =B1+B2 =C1+C2 =D1+D2

Sample Output
10 34 37 81
40 17 34 91
50 51 71 172

先以字符串形式讀入數據,分情況進行轉化,數字就轉化爲int類型,如果是表達式,應用遞歸算出每一項的值,進行相加

C

#include <stdio.h>
#include <string.h>
#include <ctype.h>
#pragma warning(disable:4996)
struct res{
	char input[1000];
	int ans;
}Res[1000][1000];
int use[1000][1000];
int calc(int r,int c)
{
	if(use[r][c])
		return Res[r][c].ans;
	int k=0,i,l=strlen(Res[r][c].input);
	if(Res[r][c].input[0]!='=')
	{
		for(i=0;i<l;i++)
			k=k*10+Res[r][c].input[i]-'0';
		return k;
	}
	int row=0,column=0;
	for(i=1;i<=l;i++)
	{
		if(isalpha(Res[r][c].input[i]))
			column=column*26+Res[r][c].input[i]-'A'+1;
		else if(isalnum(Res[r][c].input[i]))
			row=row*10+Res[r][c].input[i]-'0';
		else
		{
			k+=calc(row,column);
			row=column=0;
		}
	}
	return k;
}
int main(void)
{
	int T,r,c,i,j;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d %d",&c,&r);
		for(i=1;i<=r;i++)
			for(j=1;j<=c;j++)
				scanf("%s",Res[i][j].input);
		for(i=1;i<=r;i++)
			for(j=1;j<=c;j++)
			{
				Res[i][j].ans=calc(i,j);
				use[i][j]=1;
			}
		for(i=1;i<=r;i++)
		{
			for(j=1;j<c;j++)
				printf("%d ",Res[i][j].ans);
			printf("%d\n",Res[i][c].ans);
		}
		memset(use,0,sizeof(use));
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章