A + B Problem II(大數加法)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 522761 Accepted Submission(s): 99991

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

大數加法,就是模擬手算列豎式,只不過存儲大數要逆序存儲,方便計算,刪去前綴0,如0008+2=10,而不是0010。

C

#include <stdio.h>              //HDOJ 1002
#include <string.h>
#pragma warning(disable:4996)
char a[1000],b[1000];
int Max(int a,int b)
{
	return a>b?a:b;
}
void add(void)
{
	int a1[1005],b1[1005];
	int lena,lenb,lenmax;
	int i;
	memset(a1,0,sizeof(a1));
	memset(b1,0,sizeof(b1));
	lena=strlen(a);
	lenb=strlen(b);
	lenmax=Max(lena,lenb);
	for(i=0;i<lena;i++)
		a1[i]=a[lena-1-i]-'0';
	for(i=0;i<lenb;i++)
		b1[i]=b[lenb-1-i]-'0';
	for(i=0;i<lenmax;i++)
	{
		a1[i]+=b1[i];
		a1[i+1]+=a1[i]/10;
		a1[i]%=10;
	}
	if(!a1[i])
		i--;
	for(;i>=0;i--)
		printf("%d",a1[i]);
	putchar('\n');
}
int main(void)
{
	int T,i;
	scanf("%d",&T);
	for(i=1;i<=T;i++)
	{
		scanf("%s %s",a,b);
		printf("Case %d:\n",i);
		printf("%s + %s = ",a,b);
		add();
		if(i<T)
			putchar('\n');
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章