Humble Numbers(打表)

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

humble number的定義是他的質因數只能是2、3、5、7,有humble number=2aX3bX5cX7d,按這個規律打表即可解,但是要注意輸出格式,在代碼中會有註釋提醒

C

#include <stdio.h>
#pragma warning(disable:4996)
long long num[5843]={0,1}; //long long,題目給的最後一個實例已經超過了int能儲存的範圍
long long min(long long a,long long b)
{
	return a<b?a:b;
}
int main(void)
{
	int i2=1,i3=1,i5=1,i7=1,i;
	for(i=2;i<5843;i++)
	{
		num[i]=min(min(2*num[i2],3*num[i3]),min(5*num[i5],7*num[i7]));
		if(num[i]==2*num[i2]) i2++;
		if(num[i]==3*num[i3]) i3++;
		if(num[i]==5*num[i5]) i5++;
		if(num[i]==7*num[i7]) i7++;
	}
	while(scanf("%d",&i)&&i)
	{
		if(i%100==11||i%100==12||i%100==13)//注意這裏,11,12,13要用th後綴
			printf("The %dth humble number is %lld.\n",i,num[i]);
		else if(i%10==1)
			printf("The %dst humble number is %lld.\n",i,num[i]);
		else if(i%10==2)
			printf("The %dnd humble number is %lld.\n",i,num[i]);
		else if(i%10==3)
			printf("The %drd humble number is %lld.\n",i,num[i]);
		else
			printf("The %dth humble number is %lld.\n",i,num[i]);
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章