Elevator

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output
Print the total time on a single line for each test case.

Sample Input
1 2
3 2 3 1
0

Sample Output
17
41

電梯的移動根據命令的順序,每次到達一個目標後停留5秒
剛纔在和別人討論中知道,有和當前樓層相等的情況,要特別注意

C

#include <stdio.h>
#pragma warning(disable:4996)
int main(void)
{
	int N,time,floor,now,i,j;
	while(scanf("%d",&N)&&N)
	{
		for(time=0,now=0,i=0;i<N;i++)
		{
			scanf("%d",&floor);
			j=floor-now;
			if(j>0)
				time+=6*j;
			if(j<0)
				time+=4*-j;
			now=floor;
			time+=5;
		}
		printf("%d\n",time);
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章