GDUT_寒假訓練題解報告_圖論專題_個人題解報告——題目:L - Til the Cows Come Home

GDUT_寒假訓練題解報告_圖論專題_個人題解報告——題目:L - Til the Cows Come Home

題目:
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input

  • Line 1: Two integers: T and N

  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.
    Output

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90
    Hint
    INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.
裸的單源最短路,板子沒的說,但是我被輸入給坑死兩次了,讀題鍋。
至於到底輸入發生了什麼不可描述的事情,看這段代碼:

es[from-1][to-1]=min(value,es[from-1][to-1]);

對,他有可能兩點之間有好幾條路,你得把長的給去掉,我決定以後都要加這句話了,應該是這種圖論題目的潛規則。
完整代碼:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <climits>
#include <queue>
#include <stack>
#include <map>
//鬼畜頭文件
using namespace std;
#define INF 0x3f3f3f3f
#define ULL unsigned long long
#define LL long long
//鬼畜define
//
int es[1010][1010];
int d[1010];
bool used[1010];
int main()
{
	int n,m;
	scanf("%d %d",&m,&n);
	fill(used,used+n,false);
	fill(d,d+n,INF);
	d[0]=0;
	memset(es,INF,sizeof(es));
	for(int time=0;time<m;time++)
	{
		int from,to,value;
		scanf("%d %d %d",&from,&to,&value);
		es[from-1][to-1]=min(value,es[from-1][to-1]);
		es[to-1][from-1]=es[from-1][to-1];
	}

	while(true)
	{
		int v=-1;
		for(int time=0;time<n;time++)
		{//取最短點
			if(!used[time]&&(v==-1||d[time]<d[v]))v=time;
		}
		if(v==-1)break;
		used[v]=true;
		for(int time=0;time<n;time++)
		{
			d[time]=min(d[time],d[v]+es[v][time]);
		}
	}
	printf("%d\n",d[n-1]);

    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章