The sum problem hdu 2058

http://acm.hdu.edu.cn/showproblem.php?pid=2058


Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 

Sample Input
20 10 50 30 0 0
 

Sample Output
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
 



#include <iostream>
#include <cmath>
using namespace std;
int main()
{
	int N,M;
	while(cin>>N>>M&&N||M)
	{
		int i,j;
		
		for(j=(int)sqrt((double)(2*M));j>=1;j--){
			i=(2*M/j+1-j)/2;;
			if((2*i+j-1)*j/2==M) 
					cout<<'['<<i<<','<<i+j-1<<']'<<endl;				
			}		
		cout<<endl;
		
	}
	return 0;
}



ps

1. (i+i+j-1)*j/2=m。


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章