PAT 1145 Hashing - Average Search Time

1145 Hashing - Average Search Time (25分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

題意:給定一組數據,要求插入長度爲MSize的哈希表中。
再給定一組數據,查找各元素在哈希表中的位置。輸出總查找次數的平均值,保留一位小數。

解法:https://blog.csdn.net/qq_34594236/article/details/79814881  博主寫的很詳細

#include <bits/stdc++.h>
#define Max 11000
int n, m, msize, table[Max];
using namespace std;
int isPrime(int a) {
	if( a == 1 || a == 0) return 0;
	for(int i = 2; i <= sqrt(a); i++){
		if(a % i == 0) return 0;
	} 
	return 1;
}
int Hash(int k,int Tsize){
	return k % Tsize;
}
int main(){
	
	int a;
	memset(table, -1 , sizeof(table));
	cin >> msize >> n >> m;
	//如果給定的TSize是合數,則要重置爲離這個數最近的比它大的素數
	while(isPrime(msize) == 0) msize++;
	for(int i = 0; i < n; i++){
		cin >> a;
		int founded = 0;
		for(int j = 0; j < msize; j++){
			int d = j * j; // 處理衝突 , 二次方 探測再散列……數據結構講過 
			int tid = (Hash(a,msize) + d) % msize;
			if(table[tid] == -1) {
				founded = 1;
				table[tid] = a;
				break;
			}
		}
		if(founded == 0){
			cout << a << " cannot be inserted." << endl;
		}
	}
	int tot = 0;
	for(int i = 0; i < m; i++){
		cin >> a;
		int t = 0;
		int founded = 0;
		for(int j = 0; j < msize; j++){
			tot ++;
			int d = j * j;
			int tid = (Hash(a, msize) + d) %msize;
			if(table[tid] == a || table[tid] == -1){
				founded = 1;
				break;
			}
		}
		if(founded == 0) {
			tot++;
		}
	}
	cout << fixed << setprecision(1) << tot*1.0/m << endl;
	
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章