PAT 1133 Splitting A Linked List

1133 Splitting A Linked List (25分)

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤10​3​​). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−10​5​​,10​5​​], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

 又是一道讀不懂的題……,不過看樣例也還是可以大致明白……哎。。一遇到這種介詞,從句什麼的都發蒙。我傻了……

大致題意是:給一個鏈表,鏈表有n個結點,每個結點都有三個信息(地址,數據,下一個地址)和K,遍歷鏈表後將<0的結點先輸出,將0~k區間的結點輸出,最後輸出>k的結點

解決方法:用結構體存儲結點信息,vector 保存每一部分的結點,最後輸出。

話說,vector是真好用,insert學到了 之前都沒用過。

#include <bits/stdc++.h>
#define Max 100002
using namespace std;
struct Node{
	int add;
	int data;
	int nex;
}node[Max];
int st, n, k;
vector<Node> v;  //<0 
vector<Node> v1; // < k
vector<Node> v2; 
int main(){
	int ad;
	scanf("%d %d %d",&st, &n, &k);
	for(int i = 0; i < n; i++){
		scanf("%d",&ad);
		scanf("%d %d",&node[ad].data, &node[ad].nex);
		node[ad].add = ad;
	}
	int p = st;
	while(p != -1){
		if(node[p].data < 0) {
			v.push_back(node[p]);
		}else if(node[p].data >= 0 && node[p].data <= k){
			v1.push_back(node[p]);
		}else v2.push_back(node[p]);
		p = node[p].nex;
	}
	v.insert(v.end(), v1.begin(), v1.end());
	v.insert(v.end(), v2.begin(), v2.end());
	for(int i = 0; i < v.size(); i++){
		if(i != v.size() - 1){
			printf("%05d %d %05d\n", v[i].add, v[i].data, v[i+1].add);
		}else{
			printf("%05d %d -1\n", v[i].add, v[i].data);
		}
	}
	return 0;
} 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章