HUD 1004 Let the Balloon Rise map容器的簡單使用

題目鏈接

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink

題目大意與解題思路:
找出最受歡迎的氣球顏色,使用map容器將string類型與int類型聯繫起來即可。

AC代碼:

#include<iostream>
#include<stdio.h>
#include<map>
#include<string>
using namespace std;
map<string, int> Map;

int main() {
	int n;
	while (cin >> n&&n) {
		Map.clear();
		string tmp, ans;
		int max_num = 0;
		while (n--) {
			cin >> tmp;
			if (Map.find(tmp) == Map.end()) {
				Map[tmp] = 1;
			}
			else Map[tmp]++;
			if (Map[tmp] > max_num) {
				ans = tmp; max_num = Map[tmp];
			}
		}
		cout << ans << endl;
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章