hdu 1048 The Hardest Problem Ever (string特點運用!!!字符串輸入處理)

 

Problem Description

Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked. 
You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite: 
Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U 
Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. 
A single data set has 3 components: 

Start line - A single line, "START" 

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar 

End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT".

Output

For each data set, there will be exactly one line of output. This is the original message by Caesar. 

Sample Input


 

START NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX END START N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ END START IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ END ENDOFINPUT

 

Sample Output


 

IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

字符串輸入,模擬題。

 

思路: string kai;     char mima[1000];

不斷接受字符串,判斷是START還是END、ENDOFINPUT。根據題意做不同操作。

如果cin>>char d[50],是不會跳過空格的,所以判斷START後,用gets(字符數組)來獲取一行。

string 可以直接判斷是否是什麼字符串。 這樣ok:if(kai=="START")  ,if(mima=="不ok")

輸入kai後,重點!!:用getchar()截取掉回車,不然輸入mima的時候會直接輸空。

代碼如下:

 

#include <iostream>
#include <queue>
#include <string.h>
#include <string>
#include <algorithm>
#include <map>
#include <cstdio>
using namespace std;

int main()
{
    string kai;
   char mima[1000];
   char w;
   int len,i,j;
   while(cin>>kai)
   {
     if(kai=="START")
     {
         getchar();
       gets(mima);
      // cout<<"end"<<mima<<endl;
     }
     else if(kai=="END")
     {
         len=strlen(mima);
         for(i=0;i<len;i++)
         {
             if(mima[i]>='A'&&mima[i]<='Z')
             {
                 j=int(mima[i]-'A')-5;
                 if(j<0)
                    j+=26;
                 mima[i]=char('A'+j);
             }
         }
         cout<<mima<<endl;
     }
     else if(kai=="ENDOFINPUT")
        break;
     else
        continue;
   }
    return 0;
}

 

 

 

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章