hdu 1019 Least Common Multiple(LCM的運用)

 

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105. 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input


 

2 3 5 7 15 6 4 10296 936 1287 792 1

Sample Output


 

105 10296

水題:  求最小公倍數,其實就是兩數相乘,然後乘以最大公因數。

 

 

           最大公倍數與某個數的最大公倍數還是原本的最大公倍數不會共邊

           所以對於這題多個數字來說,我們兩個兩個算就好了。過程中可能會爆int,所以還是開long long 好點

           那我想到的處理方法就是先接受第一個數字,然後不斷輸入下一個數,每輸入一個數運算一次。

 完整代碼如下:

#include <iostream>
#include <queue>
#include <string.h>
#include <string>
#include <algorithm>
#include <map>
#include <cstdio>
using namespace std;
long long int zxgbs(long long int a,long long int b)
{
    if(a>b)
    return zxgbs(b,a);
    else
    {
      if(b%a==0)
        return a;
        return zxgbs(b%a,a);
    }
}
int main()
{
   long long  int cas,num,a,b,i,j;
  // cout<<"s";
    cin>>cas;
    while(cas--)
    {
        cin>>num;
        cin>>a;
        num--;
        while(num--)
        {
            cin>>b;
            j=zxgbs(a,b);
            //cout<<j<<endl;
            a=a*b/j;
        }
        cout<<a<<endl;
    }
    return 0;
}

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章