DP HDU 2577

0代表是燈滅的,1代表打開

對於每次操作都有兩種情況,燈滅或者燈開,所以每次都要取最小

最後再把關的狀態時的最小值輸出

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3780    Accepted Submission(s): 1735


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
3 Pirates HDUacm HDUACM
 

Sample Output
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <limits.h>
#include <math.h>
#include <limits.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define INF 999999

int dp[2][122];

int Min(int a,int b){
    return a<b?a:b;
}

bool daxie(char c){
    if(c>='A' && c<='Z'){
        return true;
    }
    else{
        return false;
    }
}

int main(){
    int t;
    char s[111];
    scanf("%d",&t);
    while(t--){
        scanf("%s",&s);
        int len = strlen(s);
        dp[0][0] = 0;//0沒有開大寫
        dp[1][0] = INF;//1開了大寫
        int i;
        for(i=1;i<=len;i++){
            if(daxie(s[i-1]) == true){//大寫
                dp[0][i] = Min(dp[0][i-1]+2,dp[1][i-1]+2);//前面的燈是滅的,要寫大寫,則需要shift。後面那個是輸入好了之後再把燈滅掉
                dp[1][i] = Min(dp[0][i-1]+2,dp[1][i-1]+1);
            }
            else{//小寫
                dp[0][i] = Min(dp[0][i-1]+1,dp[1][i-1]+2);
                dp[1][i] = Min(dp[0][i-1]+2,dp[1][i-1]+2);
            }
        }
        printf("%d\n",dp[0][len]);//最後是要燈滅的。
    }

    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章