深搜基礎

題目

B - 搜索
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input

1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output

0 1 2 2

代碼

#include <iostream>
#include <cstdio>
using namespace std;

//輸入
int m, n;
const int MAXN = 105;
char field[MAXN][MAXN];

//現在的位置(x,y)
void dfs(int x, int y)
{
    //將現在的位置替換爲*
    field[x][y] = '*';
    //循環遍歷八個方向
    for(int i = -1; i <= 1; i++)
    {
        for(int j = -1; j <= 1; j++)
         {
             int nx = x + i, ny = y + j;
             //判斷(nx,ny)是否在區域內,以及是否有@
             if(0<=nx&&nx<m&&0<=ny&&ny<n&&field[nx][ny]=='@')
             {
                 dfs(nx, ny);
             }
         }
    }
}

void solve()
{
    int ans = 0;
    for(int i = 0; i < m; i++)
    {
        for(int j = 0; j < n; j++)
        {
            //從有@的地方開始dfs
            if(field[i][j]=='@')
            {
                dfs(i, j);
                ans++;
            }
        }
    }
    printf("%d\n", ans);
}

int main()
{
    //freopen("input.txt", "r", stdin);
    while(scanf("%d%d", &m, &n))
    {
        getchar();
        if(n == 0 && m == 0) break;
        for(int i = 0; i < m; i++)
        {
            for(int j = 0; j < n; j++)
            {
                /*我發現cin能夠忽略回車的,前後兩個getchar()都可以不要
                而用scanf就必須要兩個getchar(),否則出錯
                */
                //cin >> field[i][j];
                scanf("%c", &field[i][j]);
            }
            getchar();
        }
        solve();
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章