HDU1098 Ignatius's puzzle

1098

Ignatius’s puzzle

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9936 Accepted Submission(s): 6961

Problem Description

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print “no”.

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output
The output contains a string “no”,if you can’t find a,or you should output a line contains the a.More details in the Sample Output.

Sample Input
11
100
9999

Sample Output
22
no
43

Author
eddy

Recommend
We have carefully selected several similar problems for you: 1071 1052 1049 1082 1064


f(x)=5*x^13+13*x^5+k*a*x,要使f(x)被65整除f(x)肯定爲整數,—-》x爲整數!=0,
f(x+1)=5*(x+1)^13+13*(x+1)^5+k*a*(x+1),將f(x+1)按二項式定理展開有:
f(x+1)=5*(c(13,0)*x^13+c(13,1)*x^12+c(13,2)*x^11+….+c(13,12)*x+c(13,13)*x^0)+
13*(c(5,0)x^5+c(5,1)*x^4+…..+c(5,4)*x^1+c(5,5)*x^0)+k*a(x+1)
由於c(13,1)…c(13,12)中間一定可以提取一個13,則有這些項*5之後一定可以被65整除
同理c(5,1)…c(5,4)一定可以提取一個5,則有這些項*13之後一定可以被65整除
所以:f(x+1)=5*(c(13,0)x^13+c(13,13)*x^0)+13(c(5,0)x^5+c(5,5)*x^0)+k*a(x+1)
只需要k*a*(x+1)能被65整除,即k*a*x能被65整除,要想取a最小值,x要取最小1或者-1。所以只需要18+k*a或者-18-k*a能被65整除。要使(18+k*a)%65==0,k*a肯定爲65的倍數-18=47,而k最小爲1.所以a最大爲65 就可以了。
原文

#include<stdio.h>
#include<math.h>
using namespace std;
int main() {
    int k;
    while (scanf("%d",&k) != EOF)
    {
        bool flag = true;
        for (int i = 1; i <= 65; i++)
        {
            if (i*k % 65 == 47)
            {
                printf("%d\n", i);
                flag = false;
                break;
            }
        }
        if (flag)printf("no\n");
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章