【題解】-航電OJ1013 Digital Roots

Problem Description The digital root of a positive integer is found by
summing the digits of the integer. If the resulting value is a single
digit then that digit is the digital root. If the resulting value
contains two or more digits, those digits are summed and the process
is repeated. This is continued as long as necessary to obtain a single
digit.

For example, consider the positive integer 24. Adding the 2 and the 4
yields a value of 6. Since 6 is a single digit, 6 is the digital root
of 24. Now consider the positive integer 39. Adding the 3 and the 9
yields 12. Since 12 is not a single digit, the process must be
repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the
digital root of 39.

Input The input file will contain a list of positive integers, one per
line. The end of the input will be indicated by an integer value of
zero.

Output For each integer in the input, output its digital root on a
separate line of the output.

Sample Input

24 39 0

Sample Output

6 3

題目考查九餘數定理。

#include <stdio.h>
#include <string.h>

char n[10001];

int add_digital(const char* str){
    int result = 0;
    char* pointer = (char*)str;
    while(*pointer){
        result += *pointer - 48;
        pointer++;
    }
    return result;
}

int main(){
    while(scanf("%s",n)){
        if(!strcmp(n,"0")) break;
        int sum = add_digital(n);
        printf("%d\n",(sum - 1)%9 + 1);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章