最優矩陣鏈乘 Multiplication Puzzle

Multiplication Puzzle
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9697   Accepted: 6023

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

Source

Northeastern Europe 2001, Far-Eastern Subregion


簡單的dp

//Serene
//紫書P277 最優矩陣鏈乘 Multiplication Puzzle 
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
#include<cmath>
using namespace std;
const int maxn=100+10;
int n,j,num[maxn],dp[maxn][maxn];

int main() {
	scanf("%d",&n);
	memset(dp,0x7f,sizeof(dp));
	for(int i=1;i<=n;++i) scanf("%d",&num[i]);
	for(int i=1;i<=n-1;++i) dp[i][i]=0;
	for(int len=2;len<=n-1;++len)
	  for(int i=1;i<=n-len+1;++i) {
		j=i+len-1;
		for(int k=i;k<=j;++k) dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+num[i]*num[j+1]*num[k+1]);
	  }
	cout<<dp[1][n-1];
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章