[POJ3253]-Fence Repair

Fence Repair
Time Limit: 2000MS   Memory Limit: 65536K
     

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
題目描述:
John想修築Fence需要木材,於是要去割木材,這時他需要工具,但是它不是免費的,每次切n長度的木材時需要n單位的金幣,給出John需要的木材數和木材長度,問John最小花費是多少。
解題思路:
此題符合哈弗曼樹的特性,所以需利用哈弗曼思想求解。
我這裏使用了c++中STL之multiset來進行求解,非常方便,multiset是自動升序的,每次我取第一,二個數據求和插入,並將第一,二數據刪除,最後的只剩一個時就是結果了
#include <set>
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
//#define N 100000
typedef long long LL;
//int wood[N];
int main()
{
//	freopen("data.txt","r",stdin);
	int n;
	while(~scanf("%d",&n))
	{

		multiset<int> s;
		LL res=0;
//		multiset<int>::iterator it = s.begin();
		int wood;
		for(int i = 0;i < n;++ i)
		{
			scanf("%d",&wood);
			s.insert(wood);
		}
		multiset<int>::iterator begin;
		int temp=0;
		while(s.size()>1)
		{
			begin = s.begin();
			temp = *begin;
			s.erase(begin);
			begin = s.begin();
			temp+= *begin;
			s.erase(begin);
			res+=temp;
			s.insert(temp);
		}
		printf("%lld\n",res);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章