練習賽8.1Prime Ring Problem

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 9 Accepted Submission(s) : 7

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
思路分析:這是深搜題目,重點在於要把深搜的函數思路熟悉,這個題目有點小記巧就是把質數用一個數組記,質數爲0,不是質數爲1,打表在時搜索函數。
代碼:
#include<stdio.h>
#include<string.h>
int n,visit[25],result[25],prime[38]= {0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1};
void print(int m)
{
    int k;
    for(k=1; k<m; k++)
    {
        printf("%d ",result[k]);
    }
    printf("%d\n",result[m]);
}
void dfs(int sum)
{
    int j;
    if(sum==n&&prime[result[n]+result[1]])
        print(n);
    else
    {
        for(j=2;j<=n;j++)
        {
            if(prime[result[sum]+j]&&!visit[j])
            {
                result[sum+1]=j;
                visit[j]=1;
                dfs(sum+1);
                visit[j]=0;
            }
        }


    }
}
int main()
{
    int i=1;
    while(scanf("%d",&n)!=EOF)
    {
        memset(visit,0,sizeof(int)*21);
        printf("Case %d:\n",i++);
        result[1]=1;
        visit[1]=1;
        dfs(1);
        printf("\n");
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章