8.1-line_up-dp最長遞增子序列

Description
In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are
required to line up in a straight line in front of the captain. The captain is not satisfied with the way
his soldiers are ranked, because the soldiers are standing in order by their code number: 1 , 2 , 3 ,
…, n , but they are not ranked by their height. The captain asks some soldiers to get out of the line,
and other soldiers remain in the line without changing their position. The remaining soldiers form a
new line where each soldier can see at least one of the line’s end (left or right).
Given the height of each soldier, determines the minimum number of soldiers which have to get out
of line.
Note:
A soldier can see an end, if all the soldiers between him and that end are shorter than him.
Input
The input contains two lines. The first line is the number of the soldiers n. The second line is a
sequence of n floating-point numbers with at most 5 digits precision and every two consecutive
numbers are separated by a space. The k-th number from this line represents the height of the
soldier who has the code k (1 <= k <= n).
There are some restrictions:
1. 2 <= n <= 1000
2. the height are floating numbers from the interval [0.5, 2.5]
Output
The output is the number of the soldiers who have to get out of the line.
Sample Input
8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2
Sample Output
4

動態規劃求 正反的 最長遞增子序列
數組的每一位表示以此位結尾的最長遞增串的長度,每次需要遍歷所有的可能。

注意點在於:
實際上是找到一個梯形而不是三角形,代碼的45-54行就是要說明這個
題目描述不準確,注意是梯形。
第33行的循環是因爲有這種情況:。。。23 12 45 不確定是選12這條路還是23這條路。

#include<iostream>
using namespace std;
int a[1001]={0};//第i個值表示首節點與第i個元素(一定含第i個元素)的單調遞增子序列的最大個數 
int b[1001]={0};//第i個值表示第i個元素(一定含第i個元素)與尾節點的單調遞減子序列的最大個數 
float height[1001];
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        cin>>height[i];
    }
    //dp
    for(int i=1;i<=n;i++)
    {
        a[i]=1;
        for(int j=1;j<i;j++)
        {
            if(height[i]>height[j])
            {
                if(a[j]+1>a[i])
                {
                    a[i]=a[j]+1;
                }
            }
        }
    } 
    //dp
    for(int i=n;i>=1;i--)
    {
        b[i]=1;
        for(int j=i+1;j<=n;j++)
        {
            if(height[i]>height[j])
            {
                if(b[j]+1>b[i])
                {
                    b[i]=b[j]+1;
                }
            }
        }
    }
    int curr=0;
    for(int i=1;i<n;i++)
    {
        for(int j=i+1;j<=n;j++)
        {
            if(a[i]+b[j]>curr)
            {
                curr=a[i]+b[j];
            }
        }
    }
    cout<<n-curr<<endl;
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章