oval-and-rectangle

oval-and-rectangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 470    Accepted Submission(s): 214


 

Problem Description

Patrick Star find an oval.

The half of longer axes is on the x-axis with length a.

The half of shorter axes is on the y-axis with length b.

Patrick Star plan to choose a real number c randomly from [0,b], after that, Patrick Star will get a rectangle :

1. The four vertexes of it are on the outline of the oval.

2. The two sides of it parallel to coordinate axis.

3. One of its side is y=c.

Patrick Star want to know the expectations of the rectangle's perimeter.

 

 

Input

The first line contain a integer T (no morn than 10), the following is T test case, for each test case :

Each line contains contains two integer a, b (0<b<a<105). Separated by an white space.

 

 

Output

For each test case output one line denotes the expectations of the rectangle's perimeter .

You should keep exactly 6 decimal digits and ignore the remain decimal digits. 

It is guaranted that the 7-th decimal digit of answer wont be 0 or 9.

Sample Input

1

2 1

Sample Output

8.283185


注意:此處的PI不能用庫中給定的函數M-PI,然後因爲四捨五入問題,該題是保留6位小數,但是並沒有進位,而是從第7位起,全部捨棄掉,所以不能單純的%.6f,而應該在最後的結果中減掉0.0000005.見四捨五入問題解決掉

 

 

#include <bits/stdc++.h>

using namespace std;

int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		double a,b;
		scanf("%lf %lf",&a,&b);
		printf("%.6lf", acos(-1) * a + b * 2 - 0.0000005)	;	
	}

}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章