【HD 1856】More is better

More is better

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 24381 Accepted Submission(s): 8753

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output
4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

Author
lxlcrystal@TJU

Source
HDU 2007 Programming Contest - Final

Recommend
lcy | We have carefully selected several similar problems for you: 1325 1879 1863 1875 1102

———————————————————————————————————————————————
另一類的並查集,把同一集合的長度相加到長的那一部分上,然後通過for比較記錄最大長度並輸出。
ps:這個算法相當低效 ,370MS,結構上不優化的話直接超時。
———————————————————————————————————————————————

#include<cstdio>
#include<iostream>

using namespace std;


const int MAX_N = 1e7+10;
int par[MAX_N];
int rankk[MAX_N];

void init()
{
    for( int i=0; i<=MAX_N; i++ )
    {
        par[i]=i;
        rankk[i]=1;
    }
} 

//int find( int x )
//{
//  if( par[x] == x )
//  {
//      return x;
//  }else{
//      return find(par[x]);
//  }
//} 
// 兩個find,初一看好像沒什麼區別 但是上面那個在遞歸的同時
// 每遞歸一次需要多判斷一次 ,耗時較長。 
int find(int x){  
    if (par[x]!=x) par[x]=find(par[x]);  
    return par[x];  
}  

void unite( int x,int y )
{
    x = find(x);
    y = find(y);
    if( x != y )
    {
        par[x] = y;
        rankk[y] = rankk[x]+rankk[y];
    }
}

int main()
{
    int n,a,b;
    while( ~scanf("%d",&n) )
    {
        if( n == 0 )
        {
            printf("1\n"); 
            continue;
        }
        init();
        int max = 0;
        for( int i=1; i<=n; i++ )
        {
            scanf("%d%d",&a,&b);
            if( max < a )max = a;
            if( max < b )max = b;
            unite(a,b);
        }
        int ans = 0;
        for( int i=1; i<=max; i++ )
        {
            if(rankk[i] > ans) ans = rankk[i];
        }   
        printf("%d\n",ans);
    }
    return 0;
}
發佈了62 篇原創文章 · 獲贊 6 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章