【HD 1242】Rescue (BFS)

Rescue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26491 Accepted Submission(s): 9379

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel’s friends want to save Angel. Their task is: approach Angel. We assume that “approach Angel” is to get to the position where Angel stays. When there’s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. “.” stands for road, “a” stands for Angel, and “r” stands for each of Angel’s friend.

Process to the end of the file.

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing “Poor ANGEL has to stay in the prison all his life.”

Sample Input
7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........


Sample Output
13

Author
CHEN, Xue

Source
ZOJ Monthly, October 2003

Recommend
Eddy | We have carefully selected several similar problems for you: 1240 1016 1010 1072 1241

————————————————————————————————————————————————————

BFS的題目,題解就偷懶不寫了,具體可以看這個傳送門 ->{ 類型總結 }
————————————————————————————————————————————————————

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

const int MAX_N = 205;
char map[MAX_N][MAX_N];
int vis[MAX_N][MAX_N];
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int n,m;
struct node
{
    int x,y;
    int step;
    friend bool operator < (node a,node b)
    {
        return a.step > b.step;
    }
}st,ed;

int judge(int x,int y)
{
    if( 0<=x && x<n && 0<=y && y<m && map[x][y] != '#' )
        return 1;
    else
        return 0;
}

int bfs(int x,int y)
{
    priority_queue<node>q;
    while( !q.empty() )
    {
        q.pop();
    } 
    memset(vis,0,sizeof(vis));
    st.x=x;
    st.y=y;
    st.step=0;
    vis[st.x][st.y]=1;
    q.push(st);
    while( q.size() )
    {
        st=q.top();
        if( map[st.x][st.y] == 'a' )
            return st.step;
        q.pop();
        for(int i=0; i<4; i++)
        {
            ed.x = st.x+dir[i][0];
            ed.y = st.y+dir[i][1];
            if( judge(ed.x,ed.y) && !vis[ed.x][ed.y] )
            {
                if(map[ed.x][ed.y]=='x')
                    ed.step=st.step+2;
                else
                    ed.step=st.step+1;
                vis[ed.x][ed.y]=1;
                q.push(ed);
            }
        }
    }
    return -1;
}
int main()
{
    while( ~scanf("%d%d",&n,&m) )
    {
        int i,j;
        int x=0;
        int y=0;
        int ans=0;
        for( i=0; i<n; i++ )
        {
            scanf("%s",map[i]);
            for( j=0; j<m; j++ )
            {
                if( map[i][j] == 'r' )
                {
                    x=i;
                    y=j;
                    break;
                }
            }
        }
        ans = bfs(x,y);
        if( ans == -1 )
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章