【PAT】1038. Recover the Smallest Number (30)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:

22932132143287

分析:判斷字符串怎樣結合最終得到數字和最小。 要注意結果可能前面有多個0,或者整個結果就是爲0.

正確代碼如下:

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
using namespace std;

bool cmp(string a, string b){
 	return a+b<b+a;
}

int main(int argc, char** argv) {
	int n, i;
	scanf("%d",&n);
	string str;
	vector<string> vec;
	for(i=0; i<n; i++){
		cin>>str;
		vec.push_back(str);
	}
	sort(vec.begin(), vec.end(),cmp); 
	str = "";
	for(i=0; i<vec.size(); i++){
		str += vec[i];
	}
	int index = -1;
	for(i=0; i<str.size(); i++){
		if(str[i] != '0'){
			index = i;
			break;
		}
	}
	if(index==-1){
		printf("0\n");
		return 0;
	} 
	int len = str.size()-index;
 	str = str.substr(index, len);
 	cout<<str<<endl; 
	return 0;
}







發佈了142 篇原創文章 · 獲贊 13 · 訪問量 15萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章