【PAT】 1076. Forwards on Weibo (30)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4

5

分析:在給定的層次中,判斷一條微博最多被多少人轉發。雖然是30分題,但是很簡單。

#include <iostream>
#include <vector>
#include <queue>
#include <set>
using namespace std;

struct node{
	int level;
	int id;
	vector<int> follows;
};
vector<node> user;
int level, n;
int countForwards(node x){
	int L=0, i, cnt=0, index;
	queue<node> que;
	x.level = 0;
	que.push(x);
	set<int> s;
	vector<bool> visited(n+1,false);
	visited[x.id] = true;
	while(!que.empty()){	 
		node N = que.front();
	    L = N.level;
		if(L>level)
			break;
		for(i=0; i<N.follows.size(); i++){
			index = N.follows[i];		
			if(!visited[index]){
				visited[index] = true;
				user[index].level = L+1;
				que.push(user[index]);				
			}			
		}
		que.pop();
		cnt++;
	}
	return cnt-1;
}

int main(int argc, char** argv) {
	int i;
	scanf("%d%d",&n,&level);
	int num, index;
	user.resize(n+1);
	for(i=1; i<=n; i++){
		scanf("%d",&num);
		user[i].id = i;
		for(int j=0; j<num; j++){
			scanf("%d",&index);
			user[index].follows.push_back(i);
		}
	}
	scanf("%d",&num);
	for(i=0; i<num; i++){
		scanf("%d",&index);
		printf("%d\n",countForwards(user[index]) );
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章