【PAT】1095. Cars on Campus (30)

Zhejiang University has 6 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<= 10000), the number of records, and K (<= 80000) the number of queries. Then N lines follow, each gives a record in the format

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each "in" record is paired with the chronologically next record for the same car provided it is an "out" record. Any "in" records that are not paired with an "out" record are ignored, as are "out" records not paired with an "in" record. It is guaranteed that at least one car is well paired in the input, and no car is both "in" and "out" at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00
Sample Output:
1
4
5
2
1
0
1

JH007BD ZD00001 07:20:09

陷阱一: 一輛車會進出多次;

陷阱二:關於in和out的匹配,例如一下三個數據:

JH007BD 05:09:59 in JH007BD 05:10:33 in JH007BD 12:23:42 out

實際匹配的是後兩個:

JH007BD 05:10:33 in
JH007BD 12:23:42 out

代碼如下:

#include <iostream>
#include <vector>
#include <algorithm>
#include <map>
#include <stack>
using namespace std;

struct initRec{
	string plateNum;
	int h,m,s;
	long time;
	string status;
};

struct record{ 
	record(initRec a, initRec b){
		plateNum = a.plateNum;
		h=a.h; m=a.m; s=a.s;
		leaveH=b.h; leaveM=b.m; leaveS=b.s;
		enterTime=h*3600+m*60+s;
		leaveTime=leaveH*3600+leaveM*60+leaveS;
		period=leaveTime-enterTime;
	}
	string plateNum;
	int h,m,s;
	int leaveH, leaveM, leaveS;
	long enterTime, leaveTime, period;
};

struct result{
	result(){
		totalTime = 0;
	}
	string plateNum;
	long totalTime;
};

bool cmp(initRec a, initRec b){
	if(a.plateNum != b.plateNum){
		return a.plateNum < b.plateNum;
	}else{
		return a.time < b.time;
	}
}

bool cmpByTotalTime(result a, result b){
	if(a.totalTime != b.totalTime){
		return a.totalTime > b.totalTime;
	}else{
		return a.plateNum < b.plateNum;
	}
}

bool cmpByLeaveTime(record a, record b){
	return a.leaveTime > b.leaveTime;
}
vector<record> records;
void change(vector<initRec> &vec){
	int i;
	long tNow, tLast; 
	stack<initRec> sta;
	for(i=0; i<vec.size(); i++){
		if(vec[i].status=="in"){
			if(sta.size()!=0){
				sta.pop();
			}
			sta.push(vec[i]);		 
			continue;
		}
		if( sta.size()!=0 && vec[i].status=="out"){
		    tNow = vec[i].time;
		    tLast = sta.top().time;
		    if(tNow>=tLast){
		    	records.push_back(record(sta.top(),vec[i] ));
				sta.pop();
			}
		}
	}	
}

int main(int argc, char** argv) {
	int n, k, i;
	scanf("%d%d",&n,&k);
	string plateNum, status; 
	int h, m, s, index;
	vector<initRec> recs(n);
	for(i=0; i<n; i++){
		cin>>recs[i].plateNum;
		scanf("%d:%d:%d",&recs[i].h,&recs[i].m,&recs[i].s);
		recs[i].time = recs[i].h*3600 + recs[i].m*60 + recs[i].s;
		cin>>recs[i].status;
	} 
	sort(recs.begin(), recs.end(), cmp); 
	
	string num;
	vector<initRec> vec;
	for(i=0; i<n; i++){
		initRec r = recs[i];
		if(i==0) num = r.plateNum;	
		if(r.plateNum == num ){
			vec.push_back(r);
		}else if(r.plateNum!=num){	 
			change(vec);
			vec.clear();
			num = r.plateNum;
			vec.push_back(r);
			continue;
		}
		if(i==n-1){
			change(vec);
		}
	}
	sort(records.begin(), records.end(), cmpByLeaveTime);	
	long time;  	
	int cnt;
	for(i=0; i<k; i++){
		cnt = 0;
 		scanf("%d:%d:%d",&h,&m,&s);
		time = h*3600+m*60+s;
		for(int j=0; j<records.size(); j++){
			if(records[j].leaveTime < time){
				break;
			}		
			if(records[j].enterTime<=time && records[j].leaveTime>time){
				cnt++;
			}	
		}
		printf("%d\n",cnt); 
	} 
	
	vector<result> res;
	map<string, int> plateNum2id;
	map<string, int>::iterator it;
	cnt = 0;
	for(i=0; i<records.size(); i++){
		record r = records[i];
		plateNum = r.plateNum;
		it = plateNum2id.find(plateNum);
		if(it!=plateNum2id.end()){
			int index = it->second;
			res[index].totalTime += r.period;
		}else{
			result tmp;
			tmp.plateNum = r.plateNum;
			plateNum2id[plateNum] = cnt++;
			tmp.totalTime += r.period;
			res.push_back(tmp);
		}
	}
	sort(res.begin(), res.end(), cmpByTotalTime);
	long maxPeriod = res[0].totalTime;
	for(i=0; i<res.size(); i++){
		if(res[i].totalTime == maxPeriod)	cout<<res[i].plateNum<<" ";
	}
    h = maxPeriod/3600;  
	maxPeriod %= 3600;
    m = maxPeriod/60;
    maxPeriod %= 60;
    s = maxPeriod;
    printf("%02d:%02d:%02d\n",h,m,s); 	
	return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章