【PAT】1018. Public Bike Management (30)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be inperfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.


Figure 1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

1. PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.

2. PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci (i=1,...N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0->S1->...->Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:

3 0->2->3 0

分析:找出起止點間多條最短路徑,最終輸出最優最短路。

參考:http://blog.csdn.net/sunbaigui/article/details/8657079


#include <iostream>
#include <vector>
using namespace std;
#define INF 0x6FFFFFF
vector<int> d(501,INF);
vector<bool> used(501,false);
vector<vector<int> >allPath(501);
vector<int> bikeNum;
int maxCap, staNum, proIndex, roadNum;

int min(int a, int b){
	return a<b? a:b;
}

void dijkstra(int s, int staNum, vector<vector<int> >& cost){
	d[s] = 0;
	while(true){	 
		int v = -1;
		for(int u=0; u<=staNum; u++){
			if(!used[u] &&(v==-1 ||d[u]<d[v]) )
				v = u;	
		}		
		if(v == -1) 
		    break;
		used[v] = true;
		for(int u=0; u<=staNum; u++){
			if(d[u] > d[v] + cost[v][u]){
				d[u] = d[v] + cost[v][u];
				allPath[u].clear();
				allPath[u].push_back(v);				
			}else if(d[u] == d[v] + cost[v][u]){
				allPath[u].push_back(v);
			}			
		}		
	}	
}

vector<int> possiblePath;
vector<int> bestPath;
int minSend = INF;
int minCollect = INF;
void findBestPath(int u){
	possiblePath.push_back(u);
	int i;
	if(u==0){
		//到了題目中的PBMC
		int collect = 0;
		int send = 0;
		for(i=possiblePath.size()-1; i>=0; i--){			 
			int index = possiblePath[i];
			if(index == 0){
				continue;
			} 				
			if(bikeNum[index] > maxCap/2){
				collect += bikeNum[index]-maxCap/2;
			}else if(bikeNum[index] < maxCap/2){
				collect -= (maxCap/2 - bikeNum[index]);
				if(collect<0){
					send -= collect;
					collect = 0;
				}		
			}
		}	 
 
		if(send < minSend){			
			minSend = send;
			minCollect = collect;
			bestPath = possiblePath;
		}else if(send==minSend && collect<minCollect){
			minCollect = collect;
			bestPath = possiblePath;
		}
		return ;
	}
	
	for(i=0; i<allPath[u].size(); i++){
		findBestPath(allPath[u][i]);
		possiblePath.pop_back();
	}
	
}

int main(int argc, char** argv) {	
	scanf("%d%d%d%d", &maxCap,&staNum,&proIndex,&roadNum);
	int i; 
 	bikeNum.resize(staNum+1);
	for(i=1; i<=staNum; i++){
		scanf("%d",&bikeNum[i]);
	}
	int from, to, c;
	vector< vector<int> > cost(501,vector<int>(501,INF));
 
	for(i=0; i<roadNum; i++){
		scanf("%d%d%d",&from,&to,&c);
		cost[from][to] = c;
		cost[to][from] = c;
	}
 
    dijkstra(0, staNum, cost);
    findBestPath(proIndex);    
    printf("%d 0",minSend);
    for(i=bestPath.size()-2; i>=0; i--){
    	printf("->%d",bestPath[i]);
	}
	printf(" %d\n",minCollect);
	return 0;
}



發佈了142 篇原創文章 · 獲贊 13 · 訪問量 15萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章