hdu 3530 Subsequence dp+單調隊列

Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4409    Accepted Submission(s): 1441


Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
 

Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.
 

Output
For each test case, print the length of the subsequence on a single line.
 

Sample Input
5 0 0 1 1 1 1 1 5 0 3 1 2 3 4 5
 

Sample Output
5 4
 

Source
 

Recommend
zhengfeng   |   We have carefully selected several similar problems for you:  3535 3529 3528 3527 3415 

題意:找最長的一段序列,使其中的最大最小值之差在[m,k]之間。

思路:維護兩個隊列分別記錄最大最小值,如果差大於k,就使位置靠前的隊頭+1,並標記該位置。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N=100005;
int a,ans,l,front1,back1,front2,back2;
struct node
{
    int x;
    int p;
}maxq[N],minq[N];
int main()
{
    int n,m,k;
    while(scanf("%d%d%d",&n,&m,&k)!=EOF){
        front1=back1=front2=back2=ans=l=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&a);
            while(front1<back1&&maxq[back1-1].p<a)back1--;
            while(front2<back2&&minq[back2-1].p>a)back2--;
            maxq[back1].p=a;
            maxq[back1++].x=i;
            minq[back2].p=a;
            minq[back2++].x=i;
            while(maxq[front1].p-minq[front2].p>k)
                l=maxq[front1].x>minq[front2].x?minq[front2++].x:maxq[front1++].x;
            if(maxq[front1].p-minq[front2].p>=m)ans=max(ans,i-l);
        }
        printf("%d\n",ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章