hdu 5326

Work

Problem Description


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
2
 

題目大意:給出n個人 和 k ,n-1行(a,b)表示a是b的直屬上司,要求找出管理k個人的人的個數

思        路:   鏈式前向星+dfs 
                   
                    鏈式前向星存儲邊的時候大大節省了空間和時間,比直接存鄰接表要快很多,dfs遍歷那些沒有被記錄過的點
                    就找到答案了。

代碼如下:
/*踏實!!努力!!*/
#include<iostream>
#include<stdio.h>
#include<cmath>
#include<cstring>
#include<map>
#include<queue>
#include<stack>
using namespace std;
struct{
    int v,next;
}edge[150];
int cnt,head[150],visit[150],index[150],ans;
int num[150],n,k;

void add(int u,int v)
{
    edge[cnt].v=v;
    edge[cnt].next=head[u];
    head[u]=cnt++;
    return;
}

void dfs(int u)
{
    visit[u]=1;
    index[u]=0;
    for(int i=head[u];i!=-1;i=edge[i].next){
        int to=edge[i].v;
        if(!visit[to]){
            dfs(to);
            index[u]+=(index[to]+1);
        }
    }
    if(index[u]==k)
        ans++;
    return ;
}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF){
        memset(num,0,sizeof(num));
        memset(head,-1,sizeof(head));
        memset(visit,0,sizeof(visit));
        ans=cnt=0;

        for(int i=1;i<n;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            add(a,b);
            num[b]++;
        }

        //找出那些未被標記過的點
        for(int i=1;i<=n;i++)
            if(!num[i])
               dfs(i);

        printf("%d\n",ans);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章