PAT 1044 Shopping in Mars(連續子序列分割 / 二分)

1044 Shopping in Mars (25分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

題意:給你n個連續的鑽石,每個鑽石都有相對應的價值,問該如何切割,區間裏的鑽石價值才能夠付夠M,如果沒有恰好等於的,就找能讓自己最少(>M)的價格的區間

一、連續子序列分割

每輸入一個數據就記錄其前綴和,判斷low位到i位的累加和是否超過了 M,如果超過了M,low就想右移位,記錄最小值,如果找到 = M的就直接輸出,如果最終沒有找到  =M 的,就最後再重新開始遍歷一遍 ,找區間和滿足 = 最小值的

//連續子序列分割 
#include <bits/stdc++.h>
#define Max 100001
using namespace std;
int n, m;
int pre[Max], a[Max];
int main(){
	memset(pre, 0, sizeof(pre));
	int flag = 0, low = 0, minn = 0x3f3f3f;
	cin >> n >> m;
	for(int i = 1; i <= n; i++){
		cin >> a[i];
		pre[i] = pre[i-1] + a[i]; //前綴和 
		while(pre[i] - pre[low] > m){
			minn = min(pre[i] - pre[low], minn);
			low++;
		}
		if(pre[i] - pre[low] == m){
			cout << low+1 << "-" << i << endl;
			flag = 1;
		}
	} 
	if(!flag){
		low = 0;
		for(int i = 1; i <= n; i++){
			while(pre[i] - pre[low] > minn){
				low++;
			}
			if(pre[i] - pre[low] == minn){
				cout << low+1 << "-" << i <<endl;
			}
		}
	}

	return 0;
}

二、二分

這個不錯,說的也很詳細

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章