poj1511 Invitation Cards (前向星?)

Invitation Cards
Time Limit: 8000MS   Memory Limit: 262144K
Total Submissions: 20249   Accepted: 6618

Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210


題意:求點1到所有點最短距離之和以及其餘點到點1的最短距離(有向邊)之和的總和最小值

思路:最短路徑,用spfa即可,然後果斷TLE了……

於是學習了一下所謂的前向星,好在之前也有看過,所以理解起來也沒有很大的麻煩。就好像是建幾條鏈,有關係的連

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define INF 1000000010
using namespace std;
int vis[1000010],head1[1000010],head2[1000010];
long long dis[1000010];
struct edge{
    int u,v,next;
    long long w;
}e[1000010],ee[1000010];
long long compute(int n,int m)
{
    queue<int> que;
    long long ans=0;
    for(int i=1;i<=n;i++){
        dis[i]=INF;
    }
    memset(vis,0,sizeof(vis));
    dis[1]=0;
    vis[1]=1;
    que.push(1);
    while(!que.empty()){
        int d=que.front();
        que.pop();
        vis[d]=0;
        for(int i=head1[d];i;i=e[i].next){
            if(dis[e[i].v]>dis[d]+e[i].w){
               dis[e[i].v]=dis[d]+e[i].w;
               if(!vis[e[i].v]){
                    que.push(e[i].v);
                    vis[e[i].v]=1;
               }
            }
        }
    }
    for(int i=2;i<=n;i++){
        if(dis[i]<INF)
        ans+=dis[i];
    }
    //cout<<ans<<endl;
    memset(vis,0,sizeof(vis));
    vis[1]=1;
    que.push(1);
    for(int i=1;i<=n;i++){
        dis[i]=INF;
    }
    dis[1]=0;
    while(!que.empty()){
        int d=que.front();
        que.pop();
        vis[d]=0;
        for(int i=head2[d];i;i=ee[i].next){
            if(dis[ee[i].u]>dis[d]+ee[i].w){
               dis[ee[i].u]=dis[d]+ee[i].w;
               if(!vis[ee[i].u]){
                que.push(ee[i].u);
                vis[ee[i].u]=1;
               }
            }
        }
    }
    for(int i=2;i<=n;i++){
        if(dis[i]<INF)
        ans+=dis[i];
    }
    return ans;
}
void initial(int n)
{
    memset(head1,0,sizeof(head1));
    memset(head2,0,sizeof(head2));
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n,m;
        scanf("%d%d",&n,&m);
        initial(n);
        for(int i=1;i<=m;i++){
            scanf("%d%d%lld",&e[i].u,&e[i].v,&e[i].w);
            e[i].next=head1[e[i].u];
            head1[e[i].u]=i;
            ee[i].u=e[i].u;ee[i].v=e[i].v;ee[i].w=e[i].w;
            ee[i].next=head2[e[i].v];
            head2[ee[i].v]=i;
        }
        long long ans=compute(n,m);
        printf("%lld\n",ans);
    }
    return 0;
}

在一起,免去了判斷是否相連這塊(我是這麼理解的,不對之處歡迎指正),於是果斷ac了。


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章