簡單dp算法——Sumsets

B - Sumsets

Crawling in process... Crawling failed Time Limit:2000MS     

Memory Limit:200000KB     64bit IO Format:%lld & %llu 

Description

Input

Output

Sample Input

Sample Output

Hint

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houriN), an ending hour (starting_houri < ending_houriN), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ RN) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Hint

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

解題思路:
a[n]爲和爲 n 的種類數;
 根據題目可知,加數爲2的N次方,即 n 爲奇數時等於它前一個數 n-1 的種類數 a[n-1] ,若 n 爲偶數時分加數中有無 1 討論,即關鍵是對 n 爲偶數時進行討論:
 1.n爲奇數,a[n]=a[n-1]
 2.n爲偶數:
 (1)如果加數裏含1,則一定至少有兩個1,即對n-2的每一個加數式後面 +1+1,總類數爲a[n-2];
 (2)如果加數裏沒有1,即對n/2的每一個加數式乘以2,總類數爲a[n/2];
 所以總的種類數爲:a[n]=a[n-2]+a[n/2];

代碼實現:
#include <iostream>
#include <cstdio>
#include <queue>
#include <vector>
#include <map>
#include <cmath>
#include <algorithm>

using namespace std;
int a[1000001];

int main()
{
    int   n;
    cin >> n;
    int i;
    a[1] = 1; a[2] = 2;
    for( i=3; i<=n; i++ )
    {
        if( i%2 == 1)
            a[i] = a[i-1];
        else
            a[i] = a[i-2] + a[i/2];
        a[i] = a[i] % 1000000000;
    }
    cout << a[n] <<endl;
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章