【PAT】1091. Acute Stroke (30)

One important factor to identify acute stroke (急性腦卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M by N matrix, and the maximum resolution is 1286 by 128); L (<=60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M by N matrix of 0's and 1's, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1's to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are "connected" and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.


Figure 1

Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:
3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0
Sample Output:

26

分析:三維空間的BFS。如果某個位置爲1,就要對其三維空間(前後上下左右),將相鄰的1都找出來,如果找出來的這一片區域中的1的個數不小於所給值,那麼就把這一片的值加入最終結果。


#include <iostream>
#include <vector>
#include <queue>
using namespace std;
int matrix[1286][128][60];
int xx[6] = {1,-1,0,0,0,0};
int yy[6] = {0,0,1,-1,0,0};
int zz[6] = {0,0,0,0,1,-1};

struct node{
	int x, y, z;
	node(int _x, int _y, int _z){
		x=_x; y=_y; z=_z;
	}
};
int M,N,L,T,total=0;
void bfs(int x, int y, int z){
	queue<node> que;
	que.push(node(x,y,z));
	matrix[x][y][z] = 0;
	int cnt = 1;
	while(!que.empty()){
		node n = que.front();
		for(int i=0; i<6; i++){
			int tx = n.x+xx[i];
			int ty = n.y+yy[i];
			int tz = n.z+zz[i];
			if((tz<L && tz>=0 && tx<M && tx>=0 && ty<N && ty>=0) && matrix[tx][ty][tz]==1){
				matrix[tx][ty][tz] = 0;
				cnt++;
				que.push(node(tx,ty,tz));
			}
		}
		que.pop();		
	}	
	if(cnt>=T)
		total += cnt;
}

int main(int argc, char** argv) {
	scanf("%d%d%d%d",&M,&N,&L,&T);
	int i, j, k;
	for(i=0; i<L; i++){
		for(j=0; j<M; j++)
			for(k=0; k<N; k++)
				scanf("%d",&matrix[j][k][i]);
	}
	
	for(i=0; i<L; i++){
		for(j=0; j<M; j++)
			for(k=0; k<N; k++)
				if(matrix[j][k][i]==1)
				  bfs(j,k,i);
	}
	cout<<total<<endl;
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章