hdu 1325 Is It A Tree?

http://acm.split.hdu.edu.cn/showproblem.php?pid=1325

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22816    Accepted Submission(s): 5202


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 

Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
 

Source
 


#include<bits/stdc++.h>
using namespace std;
typedef long long int ll;
const int inf = 0x7fffffff;
#define ms(x) memset((x),0,sizeof(x))

const int maxn = 1e5+10;
int fa[maxn],v[maxn];
bool flag;
void init(){
    for(int i = 1;i <= maxn; i++) fa[i] = i;
    ms(v);  flag = false;
}
int fi(int x){
    return fa[x]==x?x:fa[x]=fi( fa[x] );
}
void Lian(int x,int y){
    int p1 = fi(x),p2=fi(y);
    if( p1 == p2 ) return;
    fa[p1]=p2;
}
int main(){
    int ct=1;
    int a,b;
    init();
    while(scanf("%d%d",&a,&b)){
        if( a<0 || b<0 ) break;
        else if( a==0 && b==0 ){
            if( flag ) printf("Case %d is not a tree.\n",ct++);
            else{
                int temp = 0;
                for(int i = 1;i <= maxn;i++){
                    if( v[i]&&fa[i]==i ) temp++;
                }
                if( temp>1 ) printf("Case %d is not a tree.\n",ct++);
                else printf("Case %d is a tree.\n",ct++);
            }
            init();
        }
        else{
            Lian(a,b);  v[b]++;
            if( v[b]>1 ) flag = true;
        }
    }
    return 0;
}


ps

注意輸入結束的標誌




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章