HDU4055 Number String(計數dp)

Number String

傳送門1
傳送門2
The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter ‘I’ (increasing) if the second element is greater than the first one, otherwise write down the letter ‘D’ (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is “DIIDID”.

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.

Input

Each test case consists of a string of 1 to 1000 characters long, containing only the letters ‘I’, ‘D’ or ‘?’, representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The ‘?’ in these strings can be either ‘I’ or ‘D’.

Output

For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.

Sample Input

II
ID
DI
DD
?D
??

Sample Output

1
2
2
1
3
6

Hint

Permutation {1,2,3} has signature “II”.
Permutations {1,3,2} and {2,3,1} have signature “ID”.
Permutations {3,1,2} and {2,1,3} have signature “DI”.
Permutation {3,2,1} has signature “DD”.
“?D” can be either “ID” or “DD”.
“??” gives all possible permutations of length 3.


題意

給定一個1-n的排列,I 表示比前一個大,D 表示比前一個小,?可大可小,問有多少種排列滿足條件。

分析

定義dp[i][j] 表示前i位序列末尾是j的序列共有多少個。
輸入時用scanf("%s",A+2);會更方便。
那麼,當這個字符比前一個大時(A[i]=='I'):

dp[i][j]=dp[i][j1]+dp[i1][j1]

A[i]=='D'時:
dp[i][j]=dp[i][j+1]+dp[i1][j+1]

A[i]=='?'時:
dp[i][j]=x=1i1dp[i1][x]

顯然邊界爲dp[1][1]=1.
時間複雜度O(n2T)T 爲數據組數)

參考

CODE

#include<cstdio>
#include<cstring>
#include<memory.h>
#define mod 1000000007
#define N 1005
#define FOR(i,a,b) for(int i=(a),i##_END_=(b);i<=i##_END_;i++)
#define ROF(i,a,b) for(int i=(a),i##_END_=(b);i>=i##_END_;i--)
char a[N];
int dp[N][N];
//dp[i][j]表示處理完第i位,序列末尾j的序列共有多少個。
inline int Add(int x,int y) {
    int t=x+y;
    if(t>=mod)t-=mod;
    return t;
}

int main() {
    while(~scanf("%s",a+2)) {
        int n=strlen(a+2)+1;
        memset(dp,0,sizeof(dp));
        dp[1][1]=1;
        FOR(i,2,n) {
            if(a[i]=='D')ROF(j,i-1,1)
                dp[i][j]=Add(dp[i][j+1],dp[i-1][j]);
            else if(a[i]=='I')FOR(j,2,i)
                dp[i][j]=Add(dp[i][j-1],dp[i-1][j-1]);
            else {
                int sum=0;
                FOR(j,1,i-1)sum=Add(sum,dp[i-1][j]);
                FOR(j,1,i)dp[i][j]=sum;
            }
        }
        int ans=0;
        FOR(i,1,n)ans=Add(ans,dp[n][i]);
        printf("%d\n",ans);
    }
    return 0;
}

當然因爲每層dp都是從上一層轉移所以可以優化空間。
有這個時間幹嘛不多寫幾題

#include<cstdio>
#include<cstring>
#include<memory.h>
#define mod 1000000007
#define N 1005
#define FOR(i,a,b) for(int i=(a),i##_END_=(b);i<=i##_END_;i++)
#define ROF(i,a,b) for(int i=(a),i##_END_=(b);i>=i##_END_;i--)
char a[N];
int dp[2][N];
inline int Add(int x,int y) {
    int t=x+y;
    if(t>=mod)t-=mod;
    return t;
}

int main() {
    while(~scanf("%s",a+2)) {
        int n=strlen(a+2)+1;
        memset(dp,0,sizeof(dp));
        dp[1][1]=1;
        FOR(i,2,n) {
            int cur=i&1;
            if(a[i]=='D') {
                dp[cur][i]=0;
                ROF(j,i-1,1)
                    dp[cur][j]=Add(dp[cur][j+1],dp[!cur][j]);
            } else if(a[i]=='I') {
                dp[cur][1]=0;
                FOR(j,2,i)
                    dp[cur][j]=Add(dp[cur][j-1],dp[!cur][j-1]);
            } else {
                int sum=0;
                FOR(j,1,i-1)sum=Add(sum,dp[!cur][j]);
                FOR(j,1,i)dp[cur][j]=sum;
            }
        }
        int ans=0;
        FOR(i,1,n)ans=Add(ans,dp[n&1][i]);
        printf("%d\n",ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章