HDU3853 LOOPS

LOOPS

傳送門1
傳送門2
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.
尋找唯一的出口
The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.

Input

The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

Sample Input

2 2
0.00 0.50 0.50 0.50 0.00 0.50
0.50 0.50 0.00 1.00 0.00 0.00

Sample Output

6.000


題意

有一個RC 的迷宮,從(1,1) 走到(R,C) ,每個格子有留在原地,向右走一格,向下走一格的概率,且每走一格要2能量,求最後需要的能量期望。

分析

psy(pstay),prt(pright),pdn(pdown) 記錄概率。
當然正推和逆推都行。

逆推

逆推時是期望dp。
定義dp[i][j] 表示從(i,j)(r,c) 的期望,則

dp[i][j]=prt[i][j]dp[i][j+1]+pdn[i][j]dp[i+1][j]+21psy[i][j].
當然psy[i][j]=1dp[i][j]=0 .
順推

比較難懂!!!dalao請無視
順推時是概率dp。
定義dp[i][j] 表示從(1,1)(i,j) 的概率,則當psy[i][j] 不爲1時
dp[i][j]/=(1psy[i][j]);
dp[i+1][j]+=(dp[i][j]pdn[i][j]);
dp[i][j+1]+=(dp[i][j]prt[i][j]);
用ans記錄期望:
只要 psy[i][j]1ans+=dp[i][j]2
(如果psy[i][j]==1 則該點無法到終點或就是終點)

CODE

逆推
#include<cstdio>
#include<memory.h>
#define N 1005
#define FOR(i,a,b) for(int i=(a),i##_END_=(b);i<=i##_END_;i++)
#define ROF(i,a,b) for(int i=(a),i##_END_=(b);i>=i##_END_;i--)
using namespace std;
double dp[N][N],psy[N][N],prt[N][N],pdn[N][N];

int main() {
    int r,c;
    while(~scanf("%d%d",&r,&c)) {
        memset(dp,0,sizeof dp);
        FOR(i,1,r)FOR(j,1,c)
            scanf("%lf%lf%lf",&psy[i][j],&prt[i][j],&pdn[i][j]);
        ROF(i,r,1)ROF(j,c,1) {
            if(psy[i][j]==1)continue;
            dp[i][j]=(prt[i][j]*dp[i][j+1]+pdn[i][j]*dp[i+1][j]+2)/(1-psy[i][j]);//從它下面和右邊轉移上來
        }
        printf("%.3lf\n",dp[1][1]);
    }
    return 0;
}
順推
#include<cstdio>
#include<memory.h>
#define N 1005
#define FOR(i,a,b) for(int i=(a),i##_END_=(b);i<=i##_END_;i++)
#define ROF(i,a,b) for(int i=(a),i##_END_=(b);i>=i##_END_;i--)
double dp[N][N],psy[N][N],prt[N][N],pdn[N][N];

int main() {
    int r,c;
    while(~scanf("%d%d",&r,&c)) {
        memset(dp,0,sizeof dp);
        FOR(i,1,r)FOR(j,1,c)
            scanf("%lf%lf%lf",&psy[i][j],&prt[i][j],&pdn[i][j]);
        double ans=0;
        dp[1][1]=1;
        FOR(i,1,r)FOR(j,1,c) {
            if(psy[i][j]==1)continue;
            dp[i][j]/=(1-psy[i][j]);
            ans+=dp[i][j]*2;
            dp[i+1][j]+=(dp[i][j]*pdn[i][j]);
            dp[i][j+1]+=(dp[i][j]*prt[i][j]);
        }
        printf("%.3lf\n",ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章