HDU1260 Tickets【DP】

Tickets

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14552 Accepted Submission(s): 7216

Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:

  1. An integer K(1<=K<=2000) representing the total number of people;
  2. K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
  3. (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

Sample Input
2
2
20 25
40
1
8

Sample Output
08:00:40 am
08:00:08 am

Source
浙江工業大學第四屆大學生程序設計競賽

問題鏈接HDU1260 Tickets
問題簡述:(略)
問題分析:簡單的DP題,看代碼不解釋。
程序說明:(略)
參考鏈接:(略)
題記:(略)

AC的C++語言程序如下:

/* HDU1260 Tickets */

#include <bits/stdc++.h>

using namespace std;

const int K = 2000;
int s[K], d[K], dp[K];

int main()
{
    int n, k;
    cin >> n;
    while(n--) {
        cin >> k;
        for(int i = 0; i < k; i++) cin >> s[i];
        for(int i = 0; i < k - 1; i++) cin >> d[i];

        dp[0] = s[0];
        dp[1] = min(dp[0] + s[1], d[0]);
        for(int i = 2; i < k; i++)
            dp[i] = min(dp[i - 1] + s[i], dp[i - 2] + d[ i - 1]);

        int h, m, s;
        h = 8 + dp[k - 1] / 3600;
        m = (dp[k - 1] % 3600) / 60;
        s = dp[k - 1] % 60;

        if (h < 12) printf("%02d:%02d:%02d am\n", h, m, s);
        else printf("%02d:%02d:%02d pm\n", h, m, s);
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章