動態規劃-Number String

題目:

(很好懂的)

Number String

Time Limit: 5 Seconds      Memory Limit: 65536 KB

The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.

Input

Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.

Output

For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.

Sample Input

II
ID
DI
DD
?D
??

Sample Output

1
2
2
1
3
6


思路:

dp[i][j] 表示長度爲i的以j結尾的所有可能數。

對於dp[i-1][*] 考慮dp[i][j]。 只要在dp[i-1][*]中將>=j的數都增加一就可以了。

所以,dp[i][j] 

1. 'I'  那麼前面的那位數<=j-1

2. 'D' 那麼前面的那位數 > j但是收到後來變化的影響可以擴充到 >= j

3. '?' 前面的那位數 <= i-1



代碼:

#include <iostream>
#include <cstring>
#include <stdio.h>
#include <algorithm>
#include <cmath>
#include <map>
#include <vector>
using namespace std;

typedef long long ll;
char str[1010];
ll dp[1010][1010];
ll sum[1010][1010];
const ll mod = 1000000007;
int main() {
	while(scanf("%s",str+1) != EOF) {
		str[0] = '$';
		int len = strlen(str);
		memset(dp,0,sizeof(dp));
		memset(sum,0,sizeof(sum));
		sum[1][1] = 1;
		dp[1][1] = 1;
		
		for(int i = 2;i <= len;i ++) {
			for(int j = 1;j <= i;j ++) {
				if(str[i - 1] == 'I') {
					dp[i][j] = sum[i-1][j-1];
				} else if(str[i - 1] == 'D') {
					dp[i][j] = sum[i-1][i-1] - sum[i-1][j-1];
				}
				else {
					dp[i][j] = sum[i-1][i-1]; 
				}
				sum[i][j] = (sum[i][j-1] + dp[i][j]) % mod;
			}
		}
		printf("%lld\n",(sum[len][len] + mod) % mod);
	}
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章